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But first, some troubleshooting



The Map and Data Library
Introduction

Access data collections
Workshops and training
One-on-one consults
Appointment-only until summer 2025 (?)
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https://mdl.library.utoronto.ca/
mdl@library.utoronto.ca

11am - 5pm, Monday - Friday
416-978-5589

https://mdl.library.utoronto.ca/
mailto:mdl@library.utoronto.ca
mailto:mdl@library.utoronto.ca


Map and Data Library
Tutorials and Workshops
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https://mdl.library.utoronto.ca/support/tutorials
https://mdl.library.utoronto.ca/support/workshops-and-training

https://mdl.library.utoronto.ca/
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Finding Data
Map and Data Library
collection:
https://mdl.library.utoronto.ca/

https://mdl.library.utoronto.ca/
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Scholars Geoportal
https://geo2.scholarsportal.info/

https://geo2.scholarsportal.info/
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Planet.com
Access instructions:
https://mdl.library.utoronto.ca/collections/data-portal/planetcom

https://mdl.library.utoronto.ca/collections/data-portal/planetcom


Open data
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ArcGIS Online and Living Atlas
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Creating a New Project

Launch Pro from the
Windows Start Menu
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From the intro
screen, create a new
project using the
Map template.
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Give your new project a
name.

Choose a location on your
filesystem to save the
project.

Check the box to create a
new folder for the project.

Click OK.



9

A new project
containing a map view
will open.

The map will be empty
except for a default
basemap.

Make sure you’re
signed in with your U of
T credentials.



Shapefile (.shp) - a very common GIS vector
file format.

Other GIS-compatible vector formats:
.dwg, .dxf - CAD drawings (survey plans often use
this format)
.kml, .kmz - Google Earth file
.geojson - GeoJSON (often used in web mapping)

Working with Vector Data:
Add a data layer from a shapefile



Add a data layer from a shapefile

From the Map tab, click the Add Data button.



Navigate to the location
where you’ve saved the
sample data.

Select Neighbourhoods -
4326.shp and click OK.

Add a data layer from a shapefile



The layer will be added to your map view.
Note: This dataset was acquired from the City’s open data portal website:
https://open.toronto.ca/dataset/neighbourhoods/

Add a data layer from a shapefile

https://open.toronto.ca/dataset/neighbourhoods/


Projections

Right-click the Neighbourhoods
layer and select Properties
from the contextual menu. (Or,
double-click the layer name.)



Click on the Source tab.

Take a look at the
information in the Spatial
Reference section.

Note that this layer uses
the WGS 1984 geographic
coordinate system.

Click OK.

Projections



From the Insert tab on the
Pro Ribbon, click New
Map.



A new, blank map will be added to your project.



Click the Add Data
button.

Navigate to and open
NeighbourhoodsUTM
Zone17.shp



A second version of the Neighbourhoods layer will
be added to your new map.



Open the Properties
pane for this version of
the Neighbourhoods
layer.

Note the Spatial
Reference details.

Click OK.



Projections

Right-click the Map1
tab.

Select New Vertical
Tab Group.



Projections
Compare the two map
views side by side

Note that the shape of the
neighbourhoods layer is
quite different between
the two maps.

This is due to two
different spatial
reference systems
being used. WGS84 Geographic

Coordinate System

Universal Transverse
Mercator (UTM) Zone

17N Projection



Projections
Zoom out to view the
entire world on each map
view.

WGS84 Geographic
Coordinate System

Universal Transverse
Mercator (UTM) Zone

17N Projection



World Geodetic System 1984 (WGS84)
Scope: Worldwide
Units: Degrees (latitude and longitude)

NAD83 CSRS UTM Zone 17
Scope: Centered on -81 degrees longitude

Allows Southern Ontario to be mapped
quite accurately on a flat surface

Units: Metres

More information: https://gisgeography.com/map-projections/

https://gisgeography.com/map-projections/


Projections
To maintain spatial consistency and
accuracy, as well as avoid potential
data issues, it’s best for all layers
within a map to use the same spatial
reference.

Data can be reprojected using
ArcGIS Pro’s geoprocessing tools if
necessary.

Close the Map1 tab. We will continue
working with the WGS84 map.



Living Atlas is a curated selection of
authoritative spatial datasets provided by
Esri via the ArcGIS Online platform.

Living Atlas content can be added to ArcGIS
Pro maps as Web Services (more info
about those later).

Add data from Living Atlas or ArcGIS Online

https://livingatlas.arcgis.com/

https://livingatlas.arcgis.com/en/home/


Click the Add Data Button.

Select the Living Atlas
tab.



Type iNaturalist in
the search box and
press Enter.

Select the
iNaturalist
Observations
Feature Layer and
Click OK.



This dataset contains
crowdsourced wildlife
observations.

When zoomed out,
the individual
observations are
aggregated into bins
denoting the number
of observations per
area.



Zoom in to display
individual
observation points.

Note that the points
have been
symbolized by
category (taxonomic
class)



Visit the Living Atlas website to browse
other available datasets:

https://livingatlas.arcgis.com/en/home/

https://livingatlas.arcgis.com/en/home/


One of the most common ways of importing data into
GIS is by using spreadsheets (.csv, .xlsx, etc.)

Spreadsheets can be transformed into spatial layers if
they contain geographic information.

Spreadsheet data can also be joined to spatial layers
via a key field.

Add data from a spreadsheet



In Windows Explorer, navigate to the sample data folder.
Open tpl-branch-general-information-2023.csv in
Excel or other spreadsheet software.
Each row in the spreadsheet contains information about
one public library location. Note the Lat and Long
columns.
Exit Excel.

Add data from a spreadsheet:
XY coordinates



From Pro’s Analysis
tab, click Tools.



The Geoprocessing pane will open.

In the search bar, start typing ‘xy
table to point’.

Click the first search result to open
the tool.



Click the folder icon next to the Input Table
input box.

Navigate to the
CSV file. Select
the file and click
OK.



Select Long from the X Field dropdown and
Lat for the Y Field dropdown (if these don’t
automatically populate).

Click Run.



A new layer showing
library locations has
been added to the
map.



Review the Street
furniture-Bicycle
parking data -
4326.csv file from the
sample data in Excel.

Note that this dataset
contains no lat/long
information; however, it
does include columns
with street address
information.

Add data from a spreadsheet: Geocoding



Open the
Geoprocessing
pane by clicking the
Tools button
(Analysis tab)

Search for and open
the Geocode
Addresses tool



Provide the Input Table
parameter by clicking the
folder icon and navigating to
the bicycle parking csv file.

For the Input Address
Locator parameter, select
ArcGIS World Geocoding
Service from the dropdown.



Select Multiple Field for the
Input Address Fields
parameter.

Referring to the names of the
spreadsheet columns, provide
values for the Address or
Place, Address2, and
Neighborhood parameters.



Check Canada for the
Country.

Leave the Preferred Location
Type as Address location.

Select Address for the
Category.

Click Run.



Result: the software
will attempt to look
up locations for each
address provided.



Review the socialhousing.csv file
in the sample data folder.

This dataset details social housing
unit density exist per Toronto
neighbourhood. Neighbourhoods
are identified by a unique ID
number.

It also lists how many of these
units are geared-to-income (RGI).

Add data from a spreadsheet: Attribute Join



Add the
socialhousing.csv
file to the map.

Use the Add Data
button, or simply drag
and drop the file from
Windows Explorer into
the map view. 

Add data from a spreadsheet: Attribute Join



Recall that the Neighbourhoods layer also contains an ID for each
neighbourhood in its attribute table.
We can join the housing data to the neighbourhood polygons by matching
these IDs.

Add data from a spreadsheet: Attribute Join



Right-click the
Neighbourhoods layer in
the Contents pane.

Choose Joins and
Relates -> Add Join

Add data from a spreadsheet: Attribute Join



Specify the following:

Input Table: Neighbourhoods -
4326
Input Field: _id1
Join Table: socialhousing.csv
Join Field: Neighbourhood

 Click OK.

Add data from a spreadsheet: Attribute Join



Open the
Neighbourhoods
layer’s attribute table.

Scroll to the far right.

Data from the csv
has successfully
been joined to the
polygon layer.

Add data from a spreadsheet: Attribute Join

Joined data!



Export the layer to save a
permanently-joined
version of the data

Right-click the layer
name in the Contents
pane
From the menu,
choose Data ->
Export Features

Add data from a spreadsheet: Attribute Join



The output layer will
be saved in the project
geodatabase by
default.

Add data from a spreadsheet: Attribute Join



Web services allow data to be shared from
the internet.
To add a web service layer to Pro:

Visit https://open.toronto.ca/dataset/
web-map-services/

Expand the Download Data section

Click the Visit Page button next to the
Orthorectified Aerial Imagery - Most
current year item

Add data from a Web Service

https://open.toronto.ca/dataset/web-map-services/
https://open.toronto.ca/dataset/web-map-services/


Copy the URL (Ctrl + C)

https://gis.toronto.ca/arcgis/rest/
services/basemap/cot_ortho/MapServer

Add data from a Web Service



In Pro, click the Add Data
button (Map tab)

Select From Path...

Add data from a Web Service



Paste in the web service URL.

Click Add.

Add data from a Web Service



Result:

Add data from a Web Service



Symbology involves the use of symbols to
represent geographic features (and their
attributes) on the map

Effective symbology makes it easier for viewers
to understand complex information.

Symbology in ArcGIS Pro



Access Pro’s symbology
options:

Right-click on the
neighbourhoods_social
housing_joined layer in
the Contents Pane

Select Symbology from
the pop-up menu

The Symbology Pane
will appear.

Symbology in ArcGIS Pro



Single Symbol: All features in a layer
are represented with the same
symbol. Ideal for displaying features
of the same type.

The Neighbourhoods layer has
this symbology style by default.
To customize the symbology, click
the symbol swatch on the
Symbology pane.

Symbology in ArcGIS Pro
Types of Symbology: Single Symbol



Choose Black Outline from the
Gallery.

Symbology in ArcGIS Pro
Types of Symbology: Single Symbol



Click the Back button
to return to the main
symbology options for
the Neighbourhoods
layer

Choose Unique
Values from the
Primary symbology
dropdown

Symbology in ArcGIS Pro
Types of Symbology: Unique Values



Choose CLASSIF9 from the Field
1 dropdown menu.

Symbology in ArcGIS Pro
Types of Symbology:
Unique Values

Note: This field is not very well-named, but a review of the attribute
table shows that it specifies each neighbourhood’s Emerging Area or
NIA status.



Each polygon is now
styled to reflect the
attribute value in the
CLASSIF9 field.

Symbology in ArcGIS Pro
Types of Symbology: Unique Values



Various colour
schemes can be
selected from the
Color scheme
dropdown.

Symbology in ArcGIS Pro
Types of Symbology: Unique Values



Customize individual symbols:

Click the swatch next to
the Emerging
Neighbourhood category.

Symbology in ArcGIS Pro
Types of Symbology: Unique Values



Customize individual symbols:

Click Properties.

Symbology in ArcGIS Pro
Types of Symbology: Unique Values



Customize individual symbols:

Adjust the Fill Color,
Outline Color, and
Outline Width settings.

Symbology in ArcGIS Pro
Types of Symbology: Unique Values



Return to the primary
symbology view and select
Graduated Symbols.

Choose RGI for the field.

Symbology in ArcGIS Pro
Types of Symbology:
Graduated Symbols



Click the symbol to change
the template

Symbology in ArcGIS Pro
Types of Symbology:
Graduated Symbols



Choose a symbol from the
Gallery.

Symbology in ArcGIS Pro
Types of Symbology:
Graduated Symbols



Adjust Minimum and
Maximum symbol sizes.

Result: Attribute
information is visualized
by symbol size.

Symbology in ArcGIS Pro
Types of Symbology: Graduated Symbols



Return to the primary
symbology view and select
Graduated Colors.

Choose RGI for the field.

Choose a colour ramp.

The map symbology now
communicates information re:
the quantity of rent geared to
income housing per
neighbourhood.

Symbology in ArcGIS Pro
Types of Symbology: Graduated Colours



Open the Attribute
Table of the libraries
layer:

Right-click the
layer name and
select Show
Attribute Table,
or select the layer
name and press
Ctrl + t.

Note that some
records have <Null>
for their address

Filter Data using Definition Queries



These records also
lack latitude and
longitude information,
and are not displayed
anywhere on the
map

Let’s filter out these
layers to exclude
them from further
analysis

Filter Data using Definition Queries



Open the layer’s
Properties and select
the Definition Query
tab.

Definition queries
allow you to display
only the subset of
data that meets the
conditions you set.

Click New Definition
Query.

Filter Data using Definition Queries



Create the query: 
Where Lat is not
null And Long is not
null

Click Apply.

Click OK.

Filter Data using Definition Queries



Only the records that
are associated with a
physical location
remain

Filter Data using Definition Queries



Geoprocessing tools allow users to transform
spatial layers and related data

Typically accept input layer(s) along with other
parameters, and output a new layer.

ArcGIS Pro includes hundreds of geoprocessing
tools

Geoprocessing



From the Analysis Tab/
Geoprocessing group, click
the Tools button.

The Geoprocessing Pane will
appear.

Geoprocessing Example: Buffer



Search for Buffer and click
the first result.

Geoprocessing Example: Buffer



Parameters:
Input Features: Libraries
Distance: 1 kilometre
Click Run.

Geoprocessing Example: Buffer



Result:

Geoprocessing Example: Buffer



Raster data
Geographic information expressed as a grid of pixels (also called
‘cells’).

Each pixel represents a specific value, such as elevation,
temperature, or land cover class.

Common file formats:
TIFF/GeoTIFF - Very common in desktop publishing and GIS
Esri Grid - Proprietary ArcGIS format
NetCDF - Multidimensional raster data

Working with Raster Data



Add the dm_620483.tif
file from the workshop
data to the map

Double click on the
layer name in the
Contents pane to view
the layer’s properties.

Working with Raster Data



Note the number of
columns and rows,
number of bands, cell
size, and spatial
reference.

Working with Raster Data



The Explore tool can
be used to query pixel
(elevation) values

Working with Raster Data



From the Edit tab/Selection group,
choose the Select tool.

Working with Raster Data:
Geoprocessing



Click within the map
view to select one of
the neighbourhood
polygons.

Working with Raster Data:
Geoprocessing



From the
Geoprocessing pane,
open the Extract by
Mask tool.

Working with Raster Data:
Geoprocessing



Working with Raster Data:
Geoprocessing

Input Parameters:
Input raster: DEM

Input raster or feature
mask data: The
neighbourhoods layer

Note that the tool
honours the layer
selection

Click Run.



Working with Raster Data:
Geoprocessing

Result:



Getting Help

From the Help tab in
Pro, choose Help ->
Online Help

A website will be
launched where you
can access detailed
documentation for
the latest version of
Pro.



Getting Help

Visit https://
www.esri.com/
training/ and log in
with your UTORid.

The Course Catalog
contains many
helpful, beginner-
friendly tutorials.

https://www.esri.com/training/
https://www.esri.com/training/
https://www.esri.com/training/


Getting Help

Contact the Map and
Data Library



Next Steps
Layout creation

Analysis
       

Working with raster data

Automation

Artificial Intelligence/Machine Learning



Resources: Finding Spatial Data
MDL Geospatial Data Collection
https://mdl.library.utoronto.ca/collections/geospatial-data

Scholars GeoPortal
https://geo.scholarsportal.info

Natural Earth Data
https://www.naturalearthdata.com/

City of Toronto Open Data
https://open.toronto.ca/

Ontario GeoHub
https://geohub.lio.gov.on.ca/

Toronto and Region Conservation Authority
Open Data
https://data.trca.ca/

Open Street Map
https://www.openstreetmap.org

GIS at NASA
https://www.earthdata.nasa.gov/learn/gis

ArcGIS Hub
https://hub.arcgis.com/search

Living Atlas
https://livingatlas.arcgis.com/en/home/

USGS EarthExplorer
https://earthexplorer.usgs.gov/

https://mdl.library.utoronto.ca/collections/geospatial-data
https://geo1.scholarsportal.info/
https://www.naturalearthdata.com/
https://open.toronto.ca/
https://geohub.lio.gov.on.ca/
https://data.trca.ca/
https://www.openstreetmap.org/
https://www.earthdata.nasa.gov/learn/gis
https://hub.arcgis.com/search
https://livingatlas.arcgis.com/en/home/
https://earthexplorer.usgs.gov/


Thank you!


